Power BI – You need to upgrade to TLS 1.2 your Power BI application

imageAs you may be aware, for the past few months, Microsoft has been deprecating support for weaker TLS version (1.0, 1.1) for many of his products and services.

Power BI is the latest one to get support for TLS 1.0 and TLS 1.1 being deprecated.

As of June 2020, support for these 2 TLS version will be removed. As such you need to upgrade your Power BI applications to use TLS 1.2.

You can download the latest Power BI API SDK here https://www.nuget.org/packages/Microsoft.PowerBI.Api/

If your application is running using .Net Framework 4.4, unless you have change the default configuration, already provides you TLS 1.2 support and you (should) have nothing to do.

If your application is using an older version, you have the following line of code to get TLS 1.2 support

System.Net.ServicePointManager .SecurityProtocol |= SecurityProtocolType.Tls11 | SecurityProtocolType.Tls12;

Leave a Comment

Your email address will not be published.