Starting October 31, 2017 (in about a year), accessing your Exchange Online mailbox with Outlook client on Windows will be made using MAPI over HTTP.

This means that all client which do not support MAPI over HTTP (Outlook 2007 [by the way you should already have moved on as this is not supported anymore]) will NOT be able to connect to Exchange Online, Outlook 2010 to 2016 must ensure their client is up to date:

  • 2010 to 2013 you should have the Office December 2015 update
  • 2016 this is already supported

Be prepared Smile